Ir para conteúdo
GPS Clube

CYK

Membros
  • Total de itens

    25
  • Registro em

  • Última visita

  • Dias Ganhos

    4

CYK venceu a última vez em Setembro 7 2020

CYK tinha o conteúdo mais apreciado!

Sobre CYK

Contact Methods

  • Sexo:
    Masculino

Profile Information

  • Cidade:
    São Caetano do Sul

Country

  • País
    Brazil

Últimos Visitantes

191 visualizações

Conquistas de CYK

(1/5)

45

Reputação

  1. Boa tarde pessoal, Testei as adições dos dois novos tipos "SAU" e "Radar sem aprovação no INMETRO" neste feriado da Independência. Peguei a estrada e pude verificar que as adições dos novos tipos funcionam perfeitamente. Saudaçãoes, CYK
  2. Boa noite claudiotrg, Grato pela dica, mas não resolveu. Realmente está configuração sincroniza tudo, mas o problema está em sincronizar o fuso do aparelho. Percebi que o horário do aparelho é ajustado pelo que fica configurado em "[config]" no arquivo "system.ini" (dentro de "save\profiles\01") e não pelo fuso detectado pelo iGO: [config] last_saved_system_time="2020.09.02.|05:37:38.000" Quando sai do iGO, a hora do aparelho fica 05:37 e não com a hora do fuso detectado automaticamente. Logo, cheguei a conclusão de que se resolver o problema de ajuste de fuso horário do aparelho, que não dá a opção de fuso automático e não deixa mudar o fuso do Brasil (GMT -3), não precisaria sincronizar nada. Apesar de poder escolher outro fuso no aparelho, sempre retorna para o do Brasil. Na verdade, teria que achar um jeito de fazer funcionar outro menu inicial de outro aparelho de GPS neste Aquarius Discovery, que possua a opção de ajustar o fuso do aparelho automaticamente utilizando o sinal do satélite. At, CYK
  3. Caro jorgeultra, Vou tentar somente estas configurações, mas receio que não irão resolver. Também, tem o problema de que não existe a opção de habilitar/desabilitar a detecção automática de fuso horário no aparelho. Com havia dito, quando tento mudar para outro fuso horário, ao sair da tela de configuração de fuso horário, a hora do aparelho retorna para o fuso do Brasil e ao retornar para a tela de configuração do fuso, está configurado novamente o fuso do Brasil. At., CYK
  4. Caro jorgeultra, Achei que tivesse resolvido em parte, mas não resolveu. É justamente por ter que ficar fora do Brasil as vezes, é que preciso que o sinal do satélite pego pelo iGo Primo arrume automaticamente o horário do aparelho. E não estou conseguindo fazer com que isso ocorra. Notei que não consigo setar outro fuso horário que não seja o do Brasil no aparelho (Aquarius Discovery), mesmo selecionando outro fuso, após sair da tela de configuração e voltar, o fuso do Brasil volta a ser configurado. Só me resta testar estas configurações fora do Brasil para ver se consigo configurar outro fuso para o aparelho. Grato pelo feedback, CYK
  5. Caro jorgeultra, Boa tarde e grato pela informação, mas não resolveu. Percebi que o horário do aparelho é ajustado pelo que fica configurado em "[config]" no arquivo "system.ini" (dentro de "save\profiles\01"): [config] last_saved_system_time="2020.09.02.|05:37:38.000" Já em "[regional.timezone]" apesar da data estar errada, o horário está com a hora atual correta pego do GPS: [regional.timezone] [...]last_auto_time_sync="2001.01.17.|16:37:33.000"[...] Será que tem como configurar este parâmetro com o horário atual pego do GPS (satélite)? At., CYK
  6. Caro callgps, Poderia me dizer se estas configurações que vocâ postou são para iGo Primo em WinCE ou Android? Tenho um aparelho de GPS da marca Aquarius Discovery 4.3 com TV. Nele está instalado o iGo Primo 2.4 Fast Ultimate com skin DiMka WA P.1.7.4 Ultimate no WinCE. Estou tentando fazer com que o iGo pegue a hora pelo GPS (satélite) e atualize a hora do aparelho. Já tentei várias combinações no sys.txt, mas até agora não conseguir fazer isso. Ele somente atualiza a hora do aparelho, quando o iGo fica sem sinal do satélite e ajusto o fuso no iGo manualmente. [regional.timezone] use_auto="1 ; utiliza detecção automática de fuso horário ; sync_time=0 ;sincroniza hora com hora do aparelho sync_time="1" ; sincroniza hora com hora do GPS reset_os_timezone=1 sync_os_timezone=1 Alguém saberia como resolver este problema? Saudações, CYK
  7. Pessoal boa tarde, Desta vez, resolvi melhorar a skin "DiMka WA P.1.7.4 - Ultimate xxxxxx" wince para adicionar novos alertas para o iGo Primo Fast Ultimate, sem precisar modificar os que já existem. Para isso é necessário efetuar adições/mudanças nos seguintes arquivos: * Crie e adicione a imagem para o novo tipo nos arquivos de imagens "speedwarn.bmp", "speedwarn0.bmp" e "speedwarn1.bmp" (adicione a imagem na posição certa do número do tipo - a contagem começa com zero); * Crie a imagem do novo tipo e salve como arquivos de imagens "cameraKSM_nn", "cameraKSMMenu_nn" e "cameraKSMSS_nn" (nn é o número do tipo). NOTA: Todas as imagens estão dentro da pasta "ui_igo9\480_272" (utilize a pasta da resolução que usa) do arquivo compactado da skin. Não esqueça de fazer os backups dos arquivos originais das imagens. Precisa descompactar as imagens para edição. * Em "variable_def.ui" (dentro da pasta "ui_igo9\common\ui" do arquivo compactado da skin) editar em "<userlist wCameraSettingName name="str" tts="str" type="int" firstphrase="wstr" editspeed="bool" overspeedvalid="bool" editdirection="bool" defdirection="int" visible="bool">" os seguintes parâmetros: ; Original; <row name="" tts="" type=28 firstphrase=L"" editspeed=false overspeedvalid=false>;; Editado para novo alerta <row name="Invalid Speed Camera" tts="Invalid Speed camera," type=28 firstphrase=L"Invalid_SC" editspeed=true overspeedvalid=true> NOTA: "variable_def.ui" define se o alerta poderá ter a velocidade e direção alterados. A configuração padrão dos alertas é: <default editspeed=false overspeedvalid=false editdirection=true defdirection=0 visible=true> Para poder editar a velocidade do alerta, deve-se deixar "editspeed=true" e "overspeedvalid=true", pois o padrão é "editspeed=false" "overspeedvalid=false". Para não editar a direção do alerta, deve-se deixar "editdirection=false", pois o padrão é "editdirection=true". * Em "customized.lua" (dentro da pasta "ui_igo9\common\ui" do arquivo compactado da skin) editar os seguinte parâmetros/códigos: - Em "local skin_dictionary = {" deve-se incluir o texto e fala para o novo tipo, como por exmplo: ["Invalid Speed Camera"]="Radar sem aprovação no INMETRO", ["Invalid Speed Camera,"]="Radar sem aprovação no INMETRO,", - Em "function sd_undefined_type(n)" deve-se alterar "return n > 23 and n < 30" para que contenha os tipos não selecionáveis, como por exemplo: -- Original return n > 23 and n < 30 Neste caso, os tipos 24, 25, 26, 27, 28 e 29 não poderão ser selecionados. Já em: -- Editado para novos alertas return (n > 23 and n < 27) or (n > 28 and n < 30) Neste caso, os tipos 24, 25, 26 e 29 não poderão ser selecionados. Assim, deixa-se os tipos 27 e 28 para serem utilizados. - Em "sc_wCameraSetting_LoadDefault = function(model)" alterear as configurações do tipo desejado, como por exemplo o tipo 28: -- Original-- {type=28, visualtype=0, voicetype=0, voicealert=L"!passcam", voicesecond=0, overspeedvalid=0, overspeedtype=0, overspeeddelta=0, overspeedsound=L"", overspeedvolume=0, approachtype=0, distvalid=0, diston=0, distvisual=300, distsound=300, distsoundtts=0, voicesecondtts=0},-- Editado para novo alerta{type=28, visualtype=1, voicetype=2, voicealert=L"!passcam", voicesecond=1, overspeedvalid=1, overspeedtype=1, overspeeddelta=0, overspeedsound=L"", overspeedvolume=0, approachtype=2, distvalid=0, diston=0, distvisual=0, distsound=0, distsoundtts=1, voicesecondtts=1}, NOTA: Verifiquei que o arquivo "camera_setting114_1.txt" (dentro da pasta "\save\profiles\01\userlists") é criado quando você muda do skin padrão para o skin diMka apenas na primeira vez, para guardar estas configurações acima. Se outro arquivo "camera_setting114_1.txt" já existir, não adiantará mudar a skin usada para a skin padrão e então retornar para a skin "diMka WA P.1.7.4 - Ulimate xxxxxxxx", porque o arquivo "camera_setting114_1.txt" não será atualizado e a configuração deverá ser feita manualmente editando este arquivo. Outra forma, é apagar este arquivo para ele ser recriado da forma certa. Para habilitar ou não o teste de voz TTS para os alertas, configure de acordo como o desejado abaixo: - para falar "Segunda frase (limite de velocidade)", deixe "voicesecond=1" e "voicesecondtts=1" e para não falar deixe "voicesecond=0" e "voicesecondtts=0";- para falar "Primeira frase (distância até o ponto de alerta)", deixe "distsoundtts=1" e para não falar "distsoundtts=0";- para falar a distância utilizando as configuração do "sys.txt" (warn_distances="100:500, ...") deixe "distvalid=0" e para usar a distância pré-definida da skin, deixe "distvalid=1", mas aí deverá colocar as distâncias em "distvisual" e "distsound". Caso deixe "distvalid=0" e não houver configuração de "warn_distances=..." para o alerta, o iGo usará as distâncias pré-definidas de "distvisual" e "distsound". Além disso, verifiquei que a última coluna da configuração de cada alerta no arquivo "camera_setting114_1.txt", refere-se à habilitação ou não da prioridade do alerta por voz TTS e é inserida após a configuração de ""sc_wCameraSetting_LoadDefault = function(model)": "28;1;2;!passcam;1;1;1;0;;0;2;0;0;0;0;1;1;1" Caso algumas opções estejam habilitadas ou desabilitadas na tele de teste dos alertas, será necessário efetuar estas alterações acima no arquivo "camera_setting114_1.txt" (que está dentro da pasta "\save\profiles\01\userlists"). * Abra o arquivo "dictionary.lang" que está dentro de arquivo compactado da língua utilizada (no meu caso "Lang_Portuguese-bra" dentro da pasta "content\lang" e adicione o texto abaixo que aparecerá na tela de seleção do alerta: Invalid Speed Camera="Radar fixo sem aprovação no INMETRO" * Abra o arquivo arquivo "dictionary.voice" que está dentro de arquivo compactado da voz TTS utilizada (no meu caso "LVoice_TTS Pro-Nuance_4.5_MF-PTBR - Raquel" dentro da pasta "content\voice") e adicione os textos abaixo que serão falados por TTS na tela de teste dos alertas: Invalid Speed Camera="Radar sem aprovação no INMETRO"Invalid Speed Camera,="Radar sem aprovação no INMETRO," * No arquivo "sys.txt" na sessão de alertas, edite para incluir o novo alerta do tipo 28: [...] ; S P E E D C A M - C A T : 28[speedcam_category:28]activated_spoken_type=speechactivated_speech="Radar sem aprovação no INMETRO.";activated_min_speech_repeat_delay=-1[...]warn_distances=" ... " [...] Imagem do novo "speedwarn.bmp": Fica aqui a dica para quem quiser adicionar novos alertas de Rafael2San e juntei tudo aqui em português. Saudações,CYK
  8. Caro d780, Bom dia. Já inseri o link para baixar o arquivo no final do post. At., CYK
  9. Pessoal, Boa tarde... Sou moderador no site Maparadar e ficou definido no código de conduta do Mapardar, que não cadastramos instrumentos de fiscalização de velocidade (radar fixo, semáforo com radar ou semáforo com radar e câmara de avanço de vermelho) caso este instrumento não esteja aprovado pelo INMETRO. Desta forma, pensando nisso, efetuei além da correção de bugs, uma atualização no arquivo "speedcam.zip" do Pongo, para adicionar o alerta de radar não aprovado pelo INMETRO, utilizando o código 28 que não era utilizado pela versão original de "speedcam.zip". Também adicionei a função mais importante para mim, que é a opção de escolher qual alerta/radar, usará ou não o som de excesso de velocidade acima da velocidade do alerta/radar (overspeed_sound) que é definido no próprio iGO Nextgen, pois na versão original, não havia esta opção e este som era "tocado" para todos os alertas/radares, ou seja, ou usava-se para todos ou não usava para nenhum. Durante a navegação, será exibido a imagem abaixo no mapa e a voz TTS dirá: "[...] Radar sem aprovação no INMETRO. [...]" Assim, para quem quiser ter um aviso de um radar que foi removido ou não cadastrado no Maparadar, pode utilizar este arquivo "speedcam.zip" e outros arquivos relacionados em: [Hidden Content] At., CYK
  10. Caro fau, Boa tarde... Não sei se sua central multimídia possui estas configurações: "GPS Mix", o "GPS Mix Volume" e o "Aplicativo GPS". Configurando estes itens, o som do rádio ira reduzir a voz TTS irá falar e depois o som do rádio volta ao normal. OSB.: Não sei o que aconteceu, mas a voz TTS do Google (ou outro app TTS) parou de funcionar e a voz não era mais escutada. Então instalei uma versão do iGO Nextgen com voz TTS própria (com pasta "tts_nua_ve1") e voltou a falar normalmente. At., CYK
  11. Pessoal, Bom dia... O problema pode ser porque a configuração da porta serial e a velocidade de comunicação do receptor de sinal dos satélites estejam errados. Favor postar aqui a configuração de [gps] no "sys.txt". Ele é parecido com o abixo: [gps]port=1 ; Porta serial do receptor de sinais dos satélitesbaud=9600 ; Velocidade de comunicação da porta serial. Pelo GPSScan = 4800, original do Aquarius = 9600 e Máximo = 57600 Caro lovatto no seu caso, experimente trocar a porta serial. Comece com port=1 faça o teste para ver se pega sinal. Caso contrario troque para 2 e assim sucessivamente. Caro Agnaldo no seu caso, experimente colocar o valor mais baixo que é baud=4800 e teste o sinal. Vá aumentando até o máximo que o GPS consiga manter o sinal sem perdê-lo. At.,CYK
  12. Caro Rafael Caro rafael2sam, Boa tarde. Utilizo o iGo Nextgen em um central mumtimídia Android 8.1 e infelizmente a voz TTS do Google (engine android) é sobreposta pelo som do rádio. Logo, utilizo a voz "Luciana" do próprio Nextgen, mas a pronúncia da tarifa sai errada. Teria como passar uma dica de como resolver isso? Modificação no "dictionary.voice" e/ou "config_transform_tables" resolveriam? Também, com relação ao ux de clima, a pronúncia tamém esta incorreta. Ai invés dela falar "graus celsius" ela fala "grais celsius" . Tem como arrumar? At., CYK
  13. Boa tarde LR61, Obrigado pela dica e vou dar uma olhada. Quanto a prioridade lembro que no iGo Primo, a "última palavra" era sempre do "sys.txt". Já no Nextgen provavelmente também deve ser do "sys.txt", pois ele deriva do Primo. At., CYK
  14. Pessoal, parece que esta configuração no "sys.txt" resolveu a prioridade da voz de alerta de radar sobra a voz de manobra. Mas percebi outra coisa. Agora o som WAV que defini para alertar que a velocidade do carro está acima da velocidade do radar, corta a voz de avido do radar. Será que também há uma configuração no "sys.txt" para isso? At., CYK
×
×
  • Criar Novo...